ssl_connect returned=1 errno=0 state=sslv3 read server certificate b certificate verify failed

ssl_connect returned=1 errno=0 state=sslv3 read server certificate b certificate verify failed

PrtScr capture_2

El problema lo ocasiona en el cambio en la infraestructura de rubygems.org , en otras palabras nuestro certificado de autentificación ya no es válido, esto por los cambios en el sitio web delas gemas de ruby, por lo que debemos hacer una actualización de nuestro archivo.

1 descarga el nuevo certificado desde este enlace asegúrate de guardarlo con la extensión .pem, por lo cual al momento de guardarlo selecciona todos los archivos y elimina la extensión .txt, asi como se muestra en la imagen.

Save As

2 dirigete a la carpeta

C:\Ruby21\lib\ruby\2.1.0\rubygems

C:\Bitnami\rubystack-2\ruby\lib\ruby\2.0.0\rubygems\ssl_certs (para el caso de instalaciones de bitnami)

 

Pega el archivo .pem en esta dirección.

3 Vamos a actualizar el archivo, por lo que deberás eliminar o renombra el archivo GeoTrustGlobalCA.pem (en mi caso lo renombre).

4 renombra el archivo descargado por GeoTrustGlobalCA.pem

PrtScr capture_3

Listo ahora prueba a ejecutar nuevamente bundle install y ya deberá funcionar.

 

Mas información: https://gist.github.com/luislavena/f064211759ee0f806c88

govani

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *